User Tools

Site Tools


Forum

Using the Keyboard Maestro Forum

Where To Post

Before Asking

Before you post a question to the Keyboard Maestro Forum please:

  • Spend a little time looking through the Keyboard Maestro User Manual.
  • Use search within the Keyboard Maestro editor Help menu to try to find related actions.
  • Spend at least 5-10 minutes searching within the forum itself and with Google.

Even if you don't find what you're looking for you'll improve your knowledge of how to use Keyboard Maestro, and there's a good chance you'll ask better questions on the forum because of it.

How To Get Help

If you can't find the answers you need in the Keyboard Maestro Wiki or (User Manual), then the Keyboard Maestro Forum is a great resource to

  • Search for Q&A and Other Macros/Solutions Related to Your Issue
  • Post your questions and issues, and get help from fellow users as well as from the Keyboard Maestro owner himself.
  • Share your completed, working, macro to help others like you.

Searching the Forum for Answers

There are two ways to search the Forum:

  1. Using the Forum Search Tool by clicking on the magnifying glass (🔍) at the top right of the Forum window
  2. Using the Google site search
    1. Just like a normal Google Search, except include site:forum.keyboardmaestro.com along with your keywords:
      site:forum.keyboardmaestro.com YourKeyWords
  3. Using the Duck Duck Go Keyboard Maestro forum search !kbf

Posting Your Question or Issue to the Forum

Avoid the XY Problem of asking about your attempted ​solution​ rather than your actual problem:​

  • When you are asking a question, ensure you are clear what you are actually trying to accomplish, not just the difficulty you are having in a specific attempt at solving the problem. ​ There may be a much better way to solve the actual problem rather than resolving the difficulty with your specific attempt.
  • Always include information about a broader picture along with any attempted solution.
  • If someone asks for more information,​ do provide details.
  • If there are other solutions you have already ruled out, share why you’ve ruled them out. This gives more information about your requirements.

If you are having trouble with a macro and want help, then please post:

  • Your question with as much detail as you can
  • If it involves processing data, provide real world (not madeup) examples of:
    • Your source input data
    • How you want the data to appear after processing by your macro
  • Upload both your macro image and code (export of macro)

For help on using the Forum Editor, see Using Markdown in the Keyboard Maestro Forum

This will help others to understand your issue, and to test the macro if need be.
To get the best, fastest answer to your question, provide us with the best info you can.

How to Post/Upload Your Macro to the Forum

From the Keyboard Maestro editor

  1. Use the Share button (v7.0+) (see #1 below)
  2. Save to files, then import (see #2, Manual Upload, below)

1. Upload Using Share Button

This will create a new topic in the forum category you select.

  1. Select the Macro you wish to share in the Editor.
  2. Click on the Share button.
  3. Leave the Category on Questions & Suggestions if you are asking a question related to the macro.
  4. Change the Category to Macro Library if you are sharing a working macro for others to use.
  5. By default, both the macro and an image of the macro will be included.
  6. Click on the “New Topic” button (or before version 10.0, click the “Both” button).

and then this popup will appear

share-macro-to-forum

To include the macro in an existing topic, after the new topic is created by the Share to Forum:

  1. Select all in the new topic.
  2. Cut the selection.
  3. Cancel/Abort the new topic in the forum.
  4. Goto the existing topic, and edit your message or create a reply.
  5. Paste into the reply block.

See this video: How To Upload Macro to Existing Post in Keyboard Maestro Forum

2. Manual Upload

Follow these steps to manually export your macro to files, then upload:

  1. Click on the macro name in the Keyboard Maestro editor
  2. Goto File > Export Macro, and save wherever you'd like
  3. Goto Edit > Copy as > Copy as Image
  4. Open Mac Preview app, and goto File > New from Clipboard, and save.
  5. Go to the Keyboard Maestro forum thread, and click on reply
  6. Enter some descriptive text,
  7. Use the file upload button in the Keyboard Maestro Forum Editor to upload both files.
    1. or drag and drop files from the Finder into the Keyboard Maestro Forum Editor.
    2. or using most web browsers other than Safari you can copy and paste into the Keyboard Maestro Forum Editor.
      1. Images in the Clipboard or files copied from the Finder can be pasted.
  8. The Select Clipboard Image File macro may also be useful for posting images.

The items uploaded (shared) will be those items which are selected in the editor:

  • If you have selected a macro in the macro list, then it will be uploaded
  • If you have selected one or more Actions in a Macro, then only the Action(s) will be uploaded.

Original article posted by: Christopher Stone 2015/11/12 20:19

Forum.txt · Last modified: 2021/10/18 04:47 by peternlewis