User Tools

Site Tools


manual:How_do_I

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:How_do_I [2017/12/26 19:12]
peternlewis [How do I backup / transfer my installation to another Mac?]
manual:How_do_I [2019/06/18 01:19] (current)
peternlewis
Line 3: Line 3:
 ===== How do I install Keyboard Maestro? ===== ===== How do I install Keyboard Maestro? =====
  
-To install Keyboard~~Maestro,​ simply copy it to your Mac’s FILE{{{Applications}}} folder (or anywhere you like). ​ +To install Keyboard~~Maestro,​ simply copy it to your Mac’s FILE{{{Applications}}} folder (or anywhere you like).
  
-Note: You must use the Finder to do this will turn off Apple'​s App Translocation security feature when you move the application ​with the Finder+Note: You must use the Finder to do this since the Finder ​will turn off Apple'​s App Translocation security feature when you move the application. ​
  
 When you launch Keyboard~~Maestro it launches an invisible “Keyboard~~Maestro~~Engine” that continues to run even after you quit Keyboard~~Maestro. The engine is the process that enables your [[Macros]], [[Application Switcher]], and [[Clipboard History Switcher]] to work.  This means that they will continue to work after you quit Keyboard~~Maestro,​ as long as the engine is still running. When you launch Keyboard~~Maestro it launches an invisible “Keyboard~~Maestro~~Engine” that continues to run even after you quit Keyboard~~Maestro. The engine is the process that enables your [[Macros]], [[Application Switcher]], and [[Clipboard History Switcher]] to work.  This means that they will continue to work after you quit Keyboard~~Maestro,​ as long as the engine is still running.
Line 16: Line 16:
 Keyboard~~Maestro includes an automatic upgrade mechanism, so to upgrade Keyboard~~Maestro simply click the BUTTON{{{Install~~Update}}} button when prompted. Keyboard~~Maestro includes an automatic upgrade mechanism, so to upgrade Keyboard~~Maestro simply click the BUTTON{{{Install~~Update}}} button when prompted.
  
-To upgrade Keyboard~~Maestro manually, quit the engine by choosing [[Menus#File_Quit_Engine|Quit Engine]] from the [[Menus#​File|File ​menu]] and the editor, and replace the Keyboard~~Maestro application in your FILE{{{Applications}}} folder with the new one.  Finally, launch Keyboard Maestro to restart the engine.+To upgrade Keyboard~~Maestro manually, quit the engine by choosing ​the [[Menus#Quit_Engine|File ➤ Quit Engine menu]]and quit the editor, and replace the Keyboard~~Maestro application in your FILE{{{Applications}}} folder with the new one.  Finally, launch Keyboard Maestro to restart the engine.
  
-Keyboard~~Maestro will automatically import your previous version macros, clipboards and preferences. ​ Your old macros will be saved in the FILE{{{~/​Library/​Preferences/​Keyboard Maestro/​Keyboard Maestro Macros Saved Version ​7.plist}}} in case you wish to revert to version 7 for any reason.+Keyboard~~Maestro will automatically import your previous version macros, clipboards and preferences. ​ Your old macros will be saved in the FILE{{{~/​Library/​Preferences/​Keyboard Maestro/​Keyboard Maestro Macros Saved Version ​8.plist}}} in case you wish to revert to version 7 for any reason.
  
-If you are upgrading directly from a much older version, you will get better results by upgrading to the last of each major version in turn, ie, run 2.1.3, then 3.5, then 4.3.2, then 5.3.2, then 6.4.8, then 7.3.1, then the current version. ​ You can download old versions from our [[https://​files.stairways.com/​|file archive]].+If you are upgrading directly from a much older version, you will get better results by upgrading to the last of each major version in turn, ie, run 2.1.3, then 3.5, then 4.3.2, then 5.3.2, then 6.4.8, then 7.3.1, then 8.4.2, then the current version. ​ You can download old versions from our [[https://​files.stairways.com/​|file archive]].
  
 ===== How do I purchase Keyboard Maestro? ===== ===== How do I purchase Keyboard Maestro? =====
  
-New customers can purchase Keyboard~~Maestro for US$36 by choosing [[Menus#Keyboard_Maestro_Purchase_Keyboard_Maestro|Purchase ​Keyboard Maestro]] from the [[Menus#​Keyboard_Maestro|Keyboard Maestro menu]]. ​ Customers with five or more users should contact us for a volume discount quote.+New customers can purchase Keyboard~~Maestro for US$36 by choosing ​the [[Menus#Purchase_Keyboard_Maestro|Keyboard Maestro ​➤ Purchase ​Keyboard Maestro menu]]. ​ Customers with five or more users should contact us for a volume discount quote.
  
 You can look up your current or previous license status and serial numbers, and get information about discounted upgrades from [[https://​enquiry.stairways.com/​]]. You can look up your current or previous license status and serial numbers, and get information about discounted upgrades from [[https://​enquiry.stairways.com/​]].
Line 44: Line 44:
 If you do not receive your serial number promptly after purchasing, it may be that the email has not reached you, possibly due to spam filtering on your email service. ​ In this case, try looking up your purchase at [[https://​enquiry.stairways.com/​]] (although that will email you your serial number which might again be lost to over-zealous spam filters). If you do not receive your serial number promptly after purchasing, it may be that the email has not reached you, possibly due to spam filtering on your email service. ​ In this case, try looking up your purchase at [[https://​enquiry.stairways.com/​]] (although that will email you your serial number which might again be lost to over-zealous spam filters).
  
-Once you have your username (email address) and serial number, launch Keyboard~~Maestro and either immediately click the BUTTON{{{Use Existing License}}} button or choose [[Menus#Keyboard_Maestro_Register_Keyboard_Maestro|Register ​Keyboard Maestro]] from the [[Menus#​Keyboard_Maestro|Keyboard Maestro menu]] and then enter the username (email address) exactly as shown and the serial number exactly as shown and click the BUTTON{{{OK}}} button. ​ If you have any problems, recheck that the email address and serial number you are entering are exactly as shown (the serial number’s email address does not change even if you have changed your email address with us) and also that your license matches the major version number (eg, a version 8 license will work with version 8.x of Keyboard~~Maestro). ​ If you are already registered, the Register~~Keyboard~~Maestro menu will show you the registration details in the About Keyboard Maestro window.+Once you have your username (email address) and serial number, launch Keyboard~~Maestro and either immediately click the BUTTON{{{Use Existing License}}} button or choose [[Menus#Register_Keyboard_Maestro|Keyboard Maestro ​➤ Register ​Keyboard Maestro menu]] and then enter the username (email address) exactly as shown and the serial number exactly as shown and click the BUTTON{{{OK}}} button. ​ If you have any problems, recheck that the email address and serial number you are entering are exactly as shown (the serial number’s email address does not change even if you have changed your email address with us) and also that your license matches the major version number (eg, a version 8 license will work with version 8.x of Keyboard~~Maestro). ​ If you are already registered, the Register~~Keyboard~~Maestro menu will show you the registration details in the About Keyboard Maestro window ​— if it says it is registered to you, you are all set.
  
 ===== How do I get started? ===== ===== How do I get started? =====
  
-The first thing to do is to read the [[Quick Start]] and do the tutorial by choosing [[Menus#Help_Tutorial|Tutorial]] from the [[Menus#​Help|Help menu]]. ​ You may also want to subscribe to our Getting Started emails (Keyboard Maestro will ask you to subscribe or you can do that at your [[https://​www.stairways.com/​form/​manageemail|customer database page]] on our web site).+The first thing to do is to read the [[Quick Start]] and do the tutorial by choosing ​the [[Menus#​Tutorial|Help ​➤ Tutorial ​menu]]. ​ You may also want to subscribe to our Getting Started emails (Keyboard Maestro will ask you to subscribe or you can do that at your [[https://​www.stairways.com/​form/​manageemail|customer database page]] on our web site).
  
-After that, use your Mac normally and keep an eye out for things you do repetitively. ​ Things like:+ 
 + 
 +The best way to start using Keyboard Maestro is to start simple: 
 + 
 +* Read the [[Quick Start]]. 
 +* Do the Tutorial by choosing the [[Menus#​Tutorial|Help ➤ Tutorial menu]]. 
 +* And then grow your macros organicallystarting simple. 
 +* Join the forum (https://​forum.keyboardmaestro.com/​) and ask for help with any macros you get stuck on. 
 +* Consider enrolling in David Spark’s [[https://​learn.macsparky.com/​p/​km|Keyboard Maestro Field Guide]]. 
 + 
 +You may also want to subscribe to our Getting Started emails (Keyboard Maestro will ask you to subscribe or you can do that at your [[https://​www.stairways.com/​form/​manageemail|customer database page]] on our web site). 
 + 
 +Then use your Mac normally and keep an eye out for things you do repetitively. ​ Things like:
  
 * launch or switch to a particular application. * launch or switch to a particular application.
Line 63: Line 75:
  
 See also the [[Tips]] section. See also the [[Tips]] section.
- 
 ===== How do I create a new Macro? ===== ===== How do I create a new Macro? =====
  
-If you have not done so, use the tutorial by choosing [[Menus#Help_Tutorial|Tutorial]] from the [[Menus#​Help|Help menu]] to lead you through the process of creating a simple macro.+If you have not done so, use the tutorial by choosing ​the [[Menus#​Tutorial|Help ​➤ Tutorial ​menu]] to lead you through the process of creating a simple macro.
  
 To create a Macro, launch Keyboard~~Maestro and select the Global Macro Group, then click the BUTTON{{{+}}} button under the Macros list.  Give the Macro a name, add one or more triggers, and one or more actions. ​ The Macro is immediately active — you do not need to stop editing, quit the editor or anything else. To create a Macro, launch Keyboard~~Maestro and select the Global Macro Group, then click the BUTTON{{{+}}} button under the Macros list.  Give the Macro a name, add one or more triggers, and one or more actions. ​ The Macro is immediately active — you do not need to stop editing, quit the editor or anything else.
Line 74: Line 85:
 ===== How do I find a Macro I've used or modified recently? ===== ===== How do I find a Macro I've used or modified recently? =====
  
-You can sort the macros by name, by trigger, by date created, modified or used.  So if you launch Keyboard Maestro, select the All Macros ​pseudo ​group, and then choose [[Menus#View_Sort_Macros_by_Date_Modified|Sort Macros by Date Modified]] from the [[Menus#​View|View ​menu]] (or choose [[Menus#View_Sort_Macros_by_Date_Used|Sort Macros by Date Used]] from the [[Menus#​View|View ​menu]]) to sort the recently modified (or used) macros to the top.+You can sort the macros by name, by trigger, by date created, modified or used.  So if you launch Keyboard Maestro, select the All Macros ​smart group, and then choose ​the [[Menus#Sort_Macros_by_Date_Modified|View ➤ Sort Macros by Date Modified menu]] (or choose ​the [[Menus#Sort_Macros_by_Date_Used|View ➤ Sort Macros by Date Used menu]]) to sort the recently modified (or used) macros to the top.
  
 You can also click the BUTTON{{{◷}}} button above the macro editor pane to select from recently modified macros, or use the BUTTON{{{⌘}}} button to select from recently used macros. You can also click the BUTTON{{{◷}}} button above the macro editor pane to select from recently modified macros, or use the BUTTON{{{⌘}}} button to select from recently used macros.
Line 82: Line 93:
 You can cancel all running macros by holding all the modifiers (Control, Option, Shift and optionally Command) and clicking on the Keyboard Maestro Status Menu Icon. You can cancel all running macros by holding all the modifiers (Control, Option, Shift and optionally Command) and clicking on the Keyboard Maestro Status Menu Icon.
  
-You can cancel a specific macro by choosing ​[[Menus#​Status_Menu_Cancel|Cancel]] ​from the [[Menus#Status_Menu|Status Menu menu]] and selecting the macro. ​ This is also a useful way of seeing what macros are currently running, if any.+You can cancel a specific macro by choosing from the [[Menus#Cancel|Status Menu ➤ Cancel ​menu]] and selecting the macro. ​ This is also a useful way of seeing what macros are currently running, if any.
  
-You can also see and cancel macros by choosing ​[[Menus#​Status_Menu_Start_Debugging|Start Debugging]] from the [[Menus#Status_Menu|Status Menu menu]].+You can also see and cancel macros by choosing the [[Menus#Start_Debugging|Status Menu ➤ Start Debugging ​menu]].
  
-And finally, you can use the [[/action/Cancel_All_Macros|Cancel All Macros, Cancel Other Macros, Cancel This Macro, or Cancel Just This Macro]] actions.+And finally, you can use the [[action:Cancel_All_Macros|Cancel All Macros, Cancel Other Macros, Cancel This Macro, or Cancel Just This Macro]] actions.
  
 In desperation,​ you can quit the Keyboard Maestro Engine from the status menu, and you can launch the editor while holding all the modifiers down to quit all running engines and not launch the engine. In desperation,​ you can quit the Keyboard Maestro Engine from the status menu, and you can launch the editor while holding all the modifiers down to quit all running engines and not launch the engine.
 +
 ===== How can I get the mouse coordinates on the screen or in a window? ===== ===== How can I get the mouse coordinates on the screen or in a window? =====
  
 If possible, you should avoid using mouse click actions. They tend to be very fragile, easily broken by subtle changes to the system or applications. And they also require the screen to be in the expected state, so you usually need to add a Pause action before them to ensure the item they are clicking on is where it is expected to be. If possible, you should avoid using mouse click actions. They tend to be very fragile, easily broken by subtle changes to the system or applications. And they also require the screen to be in the expected state, so you usually need to add a Pause action before them to ensure the item they are clicking on is where it is expected to be.
  
-That said, you can use the [[Windows#​Mouse_Display_Window|Mouse Display window]] by choosing [[Menus#Window_Mouse_Display|Mouse Display]] from the [[Menus#​Window|Window ​menu]] which will let you see the mouse coordinates relative to the window or main screen. ​ Click the lock button to lock the display after a few seconds, and then put your mouse over the desired location. ​ You can then change the relative corner, and click the Clipboard buttons to copy the coordinates.+That said, you can use the [[Windows#​Mouse_Display_Window|Mouse Display window]] by choosing ​the [[Menus#Mouse_Display|Window ➤ Mouse Display menu]] which will let you see the mouse coordinates relative to the window or main screen. ​ Click the lock button to lock the display after a few seconds, and then put your mouse over the desired location. ​ You can then change the relative corner, and click the Clipboard buttons to copy the coordinates.
  
 Alternatively,​ you can simply record the click. Turn on recording in Keyboard Maestro, go to where you want to be, wait a couple seconds for the screen to be stabilised so the click will be relative to the front window, and click. Turn off recording, delete any extraneously recorded actions and you have your coordinates. ​ Immediately after recording you can adjust the relative corner of the window or screen, and the recorded coordinates will adjust to match. Alternatively,​ you can simply record the click. Turn on recording in Keyboard Maestro, go to where you want to be, wait a couple seconds for the screen to be stabilised so the click will be relative to the front window, and click. Turn off recording, delete any extraneously recorded actions and you have your coordinates. ​ Immediately after recording you can adjust the relative corner of the window or screen, and the recorded coordinates will adjust to match.
Line 109: Line 121:
 Here is how to create a Macro to insert an image when you press a Hot~~Key. Here is how to create a Macro to insert an image when you press a Hot~~Key.
  
-* Create a macro (see the [[How_do_I#​How_do_I_create_a_new_Macro?​|How do I create a new Macro?]] section) with the [[/action/​Paste_from_Named_Clipboard|Paste from Named Clipboard ​action]]. +* Create a macro (see the [[How_do_I#​How_do_I_create_a_new_Macro?​|How do I create a new Macro?]] section) with the [[action:​Set_Clipboard_to_Image ​Set Clipboard ​to Image]] action
-Select New from the clipboard popup menuwhich will create a new named clipboard and show it in the [[Windows#​Preferences_Clipboards_Pane|Clipboards preference pane]]. +Paste your image in to the actionor have the action read the image from a file or Named~~Clipboard
-* Name the new clipboard “My Image”+Then use the [[action:​Paste ​| Paste]] ​action ​to paste your image.
-Go find your image and copy it, and return to the Preferences window, click on the My Image clipboard on the left side so it is selected, and choose ​[[Menus#​Edit_Paste|Paste]] ​from the [[Menus#​Edit|Edit menu]] ​to assign the image to the clipboard.+
  
 Name the macro, and assign it whatever trigger you desire. Name the macro, and assign it whatever trigger you desire.
  
 Now whenever you trigger the macro you just created, your image will be pasted in. Now whenever you trigger the macro you just created, your image will be pasted in.
- 
 ===== How do I Insert the current date? ===== ===== How do I Insert the current date? =====
  
-You can insert text using the [[/​action/​Insert_Text|Insert Text action]], and it processes [[Tokens]]. ​ There are some basic date format tokens (such as CODE{{{%LongDate%}}}), or you can use the CODE{{{%ICUDateTime%}}} ​[[Tokens|Token]] with any [[https://​www.stairways.com/​action/​linkthru?​icudatetime|ICU date format]]. +You can insert text using the [[/​action/​Insert_Text|Insert Text action]], and it processes [[Tokens]]. ​ There are some basic date format tokens (such as the [[token:​LongDate|%LongDate%]] token), or you can use the [[token:​ICUDateTime|%ICUDateTime%]] token with any [[https://​www.stairways.com/​action/​linkthru?​icudatetime|ICU date format]].
 ===== How do I get more than one Macro Palette (Toolbar)? ===== ===== How do I get more than one Macro Palette (Toolbar)? =====
  
Line 130: Line 139:
 * When a hot key (or typed string or device key) conflicts (ie, triggers more than one macro), the [[Windows#​Conflict_Palette|Conflict Palette]] appears which lets you select from the conflicting macros. This can be an easy way to allow a single hot key to offer a multitude of similar actions. You can then use number keys or the mouse to select the desired hot key, or can use other keys to filter the palette until only one macro remains. * When a hot key (or typed string or device key) conflicts (ie, triggers more than one macro), the [[Windows#​Conflict_Palette|Conflict Palette]] appears which lets you select from the conflicting macros. This can be an easy way to allow a single hot key to offer a multitude of similar actions. You can then use number keys or the mouse to select the desired hot key, or can use other keys to filter the palette until only one macro remains.
  
-So to have more than one macro palette, create a macro group for each desired palette and configure it to show a palette as desired. Put your macros in there. Create as many of these as you like.The macros in such a macro group are only active while the palette is displayed, so if you only display it occasionally,​ especially only for one action, then they can have very simple hot keys (like plain letters for example).+So to have more than one macro palette, create a macro group for each desired palette and configure it to show a palette as desired. Put your macros in there. Create as many of these as you like. The macros in such a macro group are only active while the palette is displayed, so if you only display it occasionally,​ especially only for one action, then they can have very simple hot keys (like plain letters for example).
  
 You can control the order of macros in a macro palette (or the status menu) by prefixing their name with two characters and a closing parenthesis (eg "​01)"​ - two characters and a closing bracket). The macros will be sorted based on the code, but the code will be stripped off before display in the palette (or status menu). You can control the order of macros in a macro palette (or the status menu) by prefixing their name with two characters and a closing parenthesis (eg "​01)"​ - two characters and a closing bracket). The macros will be sorted based on the code, but the code will be stripped off before display in the palette (or status menu).
Line 167: Line 176:
 ===== How do I uninstall Keyboard Maestro? ===== ===== How do I uninstall Keyboard Maestro? =====
  
-Launch Keyboard~~Maestro and ensure the “Launch Engine at Login” preference in the [[Windows#​Preferences_General_Pane|General preference pane]] is turned off.  Then choose [[Menus#File_Quit_Engine|Quit Engine]] from the [[Menus#​File|File ​menu]] to quit the engine, and then choose [[Menus#Keyboard_Maestro_Quit_Keyboard_Maestro|Quit Keyboard Maestro]] from the [[Menus#​Keyboard_Maestro|Keyboard Maestro menu]] to quit the application.+Launch Keyboard~~Maestro and ensure the “Launch Engine at Login” preference in the [[Windows#​Preferences_General_Pane|General preference pane]] is turned off.  Then choose ​the [[Menus#Quit_Engine|File ➤ Quit Engine menu]] to quit the engine, and then choose ​the [[Menus#Quit_Keyboard_Maestro|Keyboard Maestro ​➤ Quit Keyboard Maestro menu]] to quit the application.
  
 You can then trash the Keyboard~~Maestro application from your FILE{{{Applications}}} folder, as well as the preferences in the FILE{{{~/​Library/​Application Support/​Keyboard Maestro}}} folder and FILE{{{~/​Library/​Preferences/​com.stairways.keyboardmaestro.*}}} files and logs in the FILE{{{~/​Library/​Logs/​Keyboard Maestro}}} folder. You can then trash the Keyboard~~Maestro application from your FILE{{{Applications}}} folder, as well as the preferences in the FILE{{{~/​Library/​Application Support/​Keyboard Maestro}}} folder and FILE{{{~/​Library/​Preferences/​com.stairways.keyboardmaestro.*}}} files and logs in the FILE{{{~/​Library/​Logs/​Keyboard Maestro}}} folder.
 +
 ===== How do I revert to a previous version of Keyboard Maestro? ===== ===== How do I revert to a previous version of Keyboard Maestro? =====
  
-Launch Keyboard~~Maestro and ensure the “Launch Engine at Login” preference in the [[Windows#​Preferences_General_Pane|General preference pane]] is turned off.  Then choose [[Menus#File_Quit_Engine|Quit Engine]] from the [[Menus#​File|File ​menu]] to quit the engine, and then choose [[Menus#Keyboard_Maestro_Quit_Keyboard_Maestro|Quit Keyboard Maestro]] from the [[Menus#​Keyboard_Maestro|Keyboard Maestro menu]] to quit the application. ​ You can then trash the Keyboard~~Maestro application from your FILE{{{Applications}}} folder.+Launch Keyboard~~Maestro and ensure the “Launch Engine at Login” preference in the [[Windows#​Preferences_General_Pane|General preference pane]] is turned off.  Then choose ​the [[Menus#Quit_Engine|File ➤ Quit Engine menu]] to quit the engine, and then choose ​the [[Menus#Quit_Keyboard_Maestro|Keyboard Maestro ​➤ Quit Keyboard Maestro menu]] to quit the application. ​ You can then trash the Keyboard~~Maestro application from your FILE{{{Applications}}} folder.
  
 For version 2, open the FILE{{{~/​Library/​Preferences}}} folder and the folder FILE{{{~/​Library/​Preferences/​Keyboard Maestro/​Saved Version 2}}} folder. ​ Move the files from the latter folder into the former folder. ​ Trash the FILE{{{~/​Library/​Preferences/​Keyboard Maestro}}} folder. ​ Download Keyboard~~Maestro~~2.1.3,​ if necessary, from [[https://​files.stairways.com/​keyboardmaestro/​keyboardmaestro-213.dmg]]. ​ Move Keyboard~~Maestro~~2 to the Applications folder and launch it.  Turn on the “Launch Engine at Login” preference if desired. For version 2, open the FILE{{{~/​Library/​Preferences}}} folder and the folder FILE{{{~/​Library/​Preferences/​Keyboard Maestro/​Saved Version 2}}} folder. ​ Move the files from the latter folder into the former folder. ​ Trash the FILE{{{~/​Library/​Preferences/​Keyboard Maestro}}} folder. ​ Download Keyboard~~Maestro~~2.1.3,​ if necessary, from [[https://​files.stairways.com/​keyboardmaestro/​keyboardmaestro-213.dmg]]. ​ Move Keyboard~~Maestro~~2 to the Applications folder and launch it.  Turn on the “Launch Engine at Login” preference if desired.
Line 185: Line 195:
  
 For version 7, open the FILE{{{~/​Library/​Application Support/​Keyboard Maestro}}} folder. ​ Trash the FILE{{{Keyboard Maestro Macros.plist}}} and replace it with the FILE{{{Keyboard Maestro Macros Saved Version 7.plist}}}. ​ Download Keyboard~~Maestro~~7.3.1,​ if necessary, from [[https://​files.stairways.com/​keyboardmaestro/​keyboardmaestro-731.zip]]. ​ Move Keyboard~~Maestro~~7 to the Applications folder and launch it.  Turn on the “Launch Engine at Login” preference if desired. For version 7, open the FILE{{{~/​Library/​Application Support/​Keyboard Maestro}}} folder. ​ Trash the FILE{{{Keyboard Maestro Macros.plist}}} and replace it with the FILE{{{Keyboard Maestro Macros Saved Version 7.plist}}}. ​ Download Keyboard~~Maestro~~7.3.1,​ if necessary, from [[https://​files.stairways.com/​keyboardmaestro/​keyboardmaestro-731.zip]]. ​ Move Keyboard~~Maestro~~7 to the Applications folder and launch it.  Turn on the “Launch Engine at Login” preference if desired.
 +
 +For version 8, open the FILE{{{~/​Library/​Application Support/​Keyboard Maestro}}} folder. ​ Trash the FILE{{{Keyboard Maestro Macros.plist}}} and replace it with the FILE{{{Keyboard Maestro Macros Saved Version 8.plist}}}. ​ Download Keyboard~~Maestro~~8.2.4,​ if necessary, from [[https://​files.stairways.com/​keyboardmaestro/​keyboardmaestro-824.zip]]. ​ Move Keyboard~~Maestro~~8 to the Applications folder and launch it.  Turn on the “Launch Engine at Login” preference if desired.
manual/How_do_I.1514333533.txt.gz · Last modified: 2017/12/26 19:12 by peternlewis