User Tools

Site Tools


manual:Macros

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:Macros [2019/06/18 01:23]
peternlewis
manual:Macros [2019/07/27 05:14]
peternlewis [Import Macros Safely]
Line 28: Line 28:
  
 You can add a new action by clicking the BUTTON{{{New Action}}} button or the BUTTON{{{+}}} button at the bottom of the macro detail view to display the list of actions or by choosing the [[Menus#​Insert_Action_by_Name|Edit ➤ Insert Action By Name menu]] or choosing from the [[Menus#​Insert_Action|Edit ➤ Insert Action menu]]. ​ There are many [[Macro Actions]] to choose from.  The actions you include will be executed in order. ​ You can reorder the actions by dragging them around. ​ You can copy actions by Option-Dragging or by using Copy and Paste. ​ You can delete an action by selecting it and  pressing the Delete key.  You can enable or disable actions by selecting them and clicking the BUTTON{{{✓}}} button at the bottom of the macro detail view. You can add a new action by clicking the BUTTON{{{New Action}}} button or the BUTTON{{{+}}} button at the bottom of the macro detail view to display the list of actions or by choosing the [[Menus#​Insert_Action_by_Name|Edit ➤ Insert Action By Name menu]] or choosing from the [[Menus#​Insert_Action|Edit ➤ Insert Action menu]]. ​ There are many [[Macro Actions]] to choose from.  The actions you include will be executed in order. ​ You can reorder the actions by dragging them around. ​ You can copy actions by Option-Dragging or by using Copy and Paste. ​ You can delete an action by selecting it and  pressing the Delete key.  You can enable or disable actions by selecting them and clicking the BUTTON{{{✓}}} button at the bottom of the macro detail view.
 +
 +You can control or right click on a macro group to Disable, Enable, Rename, Duplicate, or Export it.
  
 An easy way to generate macro actions is to turn on recording by clicking the BUTTON{{{Record}}} button at the bottom of the macro detail view and proceeding to show Keyboard~~Maestro what you want to do.  Then turn recording back off and look through the actions. ​ Chances are you will need to delete or adjust some of the recorded actions to make a robust macro, but this will be quicker than creating each action manually. An easy way to generate macro actions is to turn on recording by clicking the BUTTON{{{Record}}} button at the bottom of the macro detail view and proceeding to show Keyboard~~Maestro what you want to do.  Then turn recording back off and look through the actions. ​ Chances are you will need to delete or adjust some of the recorded actions to make a robust macro, but this will be quicker than creating each action manually.
Line 91: Line 93:
 You may use any of the following to import the macro file (`.kmmacros`):​ You may use any of the following to import the macro file (`.kmmacros`):​
   * Double-click on the macro file in the Mac Finder.   * Double-click on the macro file in the Mac Finder.
-  * In the Keyboard Maestro app, goto _File > Import Macros ​Safe..._ and select the macro file.+  * In the Keyboard Maestro app, goto _File > Import Macros ​Safely..._ and select the macro file.
   * In some browsers, click on the downloaded file icon at the bottom of the browser window.   * In some browsers, click on the downloaded file icon at the bottom of the browser window.
  
Line 97: Line 99:
 ==== Import Macros Safely ==== ==== Import Macros Safely ====
  
-(!) You should be aware that the macros will be imported in the same state, triggers, and macro group that they were saved in.  By default, macros are imported disabled unless you hold the Option key down.  Importing them disabled is important, because otherwise **this could result in the imported Macro being triggered (executed) as soon as it is imported.** ​ If you are at all uncertain about the source of the macros, ensure you import the macros disabled or choose the [[Menus#Import_Macros_Safe|File ➤ Import Macros ​Safe menu]].+(!) You should be aware that the macros will be imported in the same state, triggers, and macro group that they were saved in.  By default, macros are imported disabled unless you hold the Option key down.  Importing them disabled is important, because otherwise **this could result in the imported Macro being triggered (executed) as soon as it is imported.** ​ If you are at all uncertain about the source of the macros, ensure you import the macros disabled or choose the [[Menus#Import_Macros_Safely|File ➤ Import Macros ​Safely ​menu]].
  
 See also the [[Macro Groups]], [[Macro Actions]], [[Macro Triggers]], [[:​Macro_Activation]],​ [[Macro Examples]], [[Macro Library]] and [[Recording]] sections. See also the [[Macro Groups]], [[Macro Actions]], [[Macro Triggers]], [[:​Macro_Activation]],​ [[Macro Examples]], [[Macro Library]] and [[Recording]] sections.
manual/Macros.txt · Last modified: 2019/07/27 05:14 by peternlewis