User Tools

Site Tools


manual:Menus

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:Menus [2018/07/11 17:45]
JMichaelTX [Make Alias]
manual:Menus [2019/08/12 00:13] (current)
peternlewis
Line 1: Line 1:
-{{:​manual:​menu-icon.png?​nolink|}} +====== Menus ====== 
-====== ​Keyboard Maestro App Menus ======+
 Below is a complete list of all menus. ​ Note that in some cases you must hold down the Option Key <​kbd>​⌥</​kbd>​ (or <​kbd>​Alt</​kbd>​ or <​kbd>​Opt</​kbd>​) to see the menu item.  For example, the "​Expand All Actions"​ item in the Actions menu. Below is a complete list of all menus. ​ Note that in some cases you must hold down the Option Key <​kbd>​⌥</​kbd>​ (or <​kbd>​Alt</​kbd>​ or <​kbd>​Opt</​kbd>​) to see the menu item.  For example, the "​Expand All Actions"​ item in the Actions menu.
 +
 ===== Keyboard Maestro ===== ===== Keyboard Maestro =====
  
Line 20: Line 21:
 ==== Register Keyboard Maestro ==== ==== Register Keyboard Maestro ====
  
-The *Register Keyboard Maestro* command in the *Keyboard Maestro* menu displays the serial number entry window allowing you to enter your username (email address) and serial number. ​ Make sure you enter them exactly as sent to you.+The *Register Keyboard Maestro* command in the *Keyboard Maestro* menu displays the serial number entry window allowing you to enter your username (email address) and serial number. ​ Make sure you enter them exactly as sent to you.  If your email address shows up as “Registered to” in the About Keyboard Maestro box, then you are already registered.
  
 ==== Check For Update ==== ==== Check For Update ====
Line 48: Line 49:
 ==== Quit Keyboard Maestro ==== ==== Quit Keyboard Maestro ====
  
-The *Quit Keyboard Maestro* command in the *Keyboard Maestro* menu will Quit Keyboard~~Maestro.  ​the Keyboard~~Maestro~~Engine will remain running and all enabled Keyboard~~Maestro features will continue to operate (unless you have specifically quit the Keyboard~~Maestro~~Engine).+The *Quit Keyboard Maestro* command in the *Keyboard Maestro* menu will Quit Keyboard~~Maestro.  ​The Keyboard~~Maestro~~Engine will remain running and all enabled Keyboard~~Maestro features will continue to operate (unless you have specifically quit the Keyboard~~Maestro~~Engine).
  
 ===== File ===== ===== File =====
Line 65: Line 66:
  
 The *New Macro* command in the *File* menu creates and starts editing a new macro. The *New Macro* command in the *File* menu creates and starts editing a new macro.
 +
 +==== New Editor Window ====
 +
 +The *New Editor Window* command in the *File* menu creates a new editor window. ​ Closing the last editor window will quit the Keyboard~~Maestro editor (the Keyboard~~Maestro~~Engine will continue operating as usual).
  
 ==== Close ==== ==== Close ====
  
 The *Close* command in the *File* menu closes the front window. The *Close* command in the *File* menu closes the front window.
 +
 +==== Close All ====
 +
 +The *Close All* command in the *File* menu closes all the windows and quits the Keyboard~~Maestro editor (the Keyboard~~Maestro~~Engine will continue operating as usual). ​ Hold the Option key down to select this menu item.
  
 ==== Run Macro ==== ==== Run Macro ====
Line 82: Line 91:
 ==== Export Macros ==== ==== Export Macros ====
  
-The *Export Macros* command in the *File* menu exports the selected macros to a file that you can import on another Mac.  This is one way to transfered macros from one Mac to another.+The *Export Macros* command in the *File* menu exports the selected macros to a file that you can import on another Mac.  This is one way to transfered macros from one Mac to another ​or to share macros with friends or colleagues.
  
 ==== Export as Macro Library ==== ==== Export as Macro Library ====
Line 94: Line 103:
 ==== Export as Trigger File ==== ==== Export as Trigger File ====
  
-The * Export as Trigger File* command in the *File* menu lets you save a file that will trigger a macro when opened (that is, a file you can open in the Finder to trigger a macro).+The *Export as Trigger File* command in the *File* menu lets you save a file that will trigger a macro when opened (that is, a file you can open in the Finder to trigger a macro).
  
 ==== Import Actions ==== ==== Import Actions ====
Line 100: Line 109:
 The *Import Actions* command in the *File* menu lets you select a saved action file and imports the actions it contains into the current macro. The *Import Actions* command in the *File* menu lets you select a saved action file and imports the actions it contains into the current macro.
  
-==== Import Macros ​Disabled ​====+==== Import Macros ​Safely ​====
  
-The *Import Macros ​Disabled* command in the *File* menu lets you select a saved macro file and imports the macros it contains, disabling them (either disabling created macro groups, or disabling the contained macros as appropriate).+The *Import Macros ​Safely* command in the *File* menu lets you select a saved macro file and imports the macros it contains, disabling them (either disabling created macro groups, or disabling the contained macros as appropriate).
  
-If you do not completely trust the source of the macros, you should import them disabled.+If you do not completely trust the source of the macros, you should import them this way.
  
 ==== Import Macros ==== ==== Import Macros ====
  
-The *Import Macros* command in the *File* menu lets you select a saved macro file and imports the macros it contains. ​ Hold the Option key down to select this menu item.  Macros imported this way could trigger immediately,​ so import the macros disabled unless ​you completely trust the source of the macros.+The *Import Macros* command in the *File* menu lets you select a saved macro file and imports the macros it contains. ​ Hold the Option key down to select this menu item.  Macros imported this way could trigger immediately,​ so use this command only if you completely trust the source of the macros.
  
 ==== Import to Macro Library ==== ==== Import to Macro Library ====
Line 118: Line 127:
 ==== Revert Macros ==== ==== Revert Macros ====
  
-The *Revert Macros* ​command ​in the *File* menu lets you revert to a previous version of your macros. ​ If you find you have really messed up your macros, you can revert ​to how they were when you first launched Keyboard Maestro, or how they were yesterday or even several days ago. +The *Revert Macros* ​menu in the *File* menu lets you revert to a previous version of your macros. ​ If you find you have really messed up your macros, you can restore your macros ​to a backup version of how they were when you first launched Keyboard Maestro, or how they were yesterday or even several days ago.
- +
-Keywords: ​ @Restore @Macros @Version+
  
 ==== Start Syncing Macros ==== ==== Start Syncing Macros ====
Line 142: Line 149:
 ==== Launch Engine ==== ==== Launch Engine ====
  
-The *Launch Engine* command in the *File* menu lets you start the Keyboard~~Maestro~~Engine manually. ​ The Keyboard~~Maestro~~Engine performs all the Macro, Application~~Switcher,​ Window~~Switcher and Clipboard~~Switcher functions even while Keyboard~~Maestro itself is not running. ​ It is launched automatically as a Startup Item when you login (assuming you have not disabled ​that in the [[Windows#​Preferences_Window|Preferences window]]) or any time you launch Keyboard~~Maestro. ​ If it is not running for any reason you can start it manually with this command. This menu item only exists while the Keyboard~~Maestro~~Engine is not running.+The *Launch Engine* command in the *File* menu lets you start the Keyboard~~Maestro~~Engine manually. ​ The Keyboard~~Maestro~~Engine performs all the Macro, Application~~Switcher,​ Window~~Switcher and Clipboard~~Switcher functions even while Keyboard~~Maestro itself is not running. ​ It is launched automatically as a Startup Item when you login (assuming you have enabled ​that in the [[Windows#​Preferences_Window|Preferences window]]) or any time you launch Keyboard~~Maestro. ​ If it is not running for any reason you can start it manually with this command. This menu item only exists while the Keyboard~~Maestro~~Engine is not running.
  
 ==== Quit Engine ==== ==== Quit Engine ====
Line 183: Line 190:
 The *Copy as XML* command in the *Copy as* sub-menu in the *Edit* menu menu allows you to copy the selected macro or actions as XML. The *Copy as XML* command in the *Copy as* sub-menu in the *Edit* menu menu allows you to copy the selected macro or actions as XML.
  
-==== Copy UID ====+==== Copy UUID ====
  
-The *Copy UID* command in the *Copy as* sub-menu in the *Edit* menu menu allows you to copy the selected macro or macro group’s ​UID.+The *Copy UUID* command in the *Copy as* sub-menu in the *Edit* menu menu allows you to copy the selected macro or macro group’s ​UUID (Universally Unique ID).
  
 ==== Paste ==== ==== Paste ====
Line 202: Line 209:
 ==== Deselect All ==== ==== Deselect All ====
  
-The *Deselect All* command in the *Edit* menu deselects all text or items. +The *Deselect All* command in the *Edit* menu deselects all text or items. ​ Hold the Option key down to select this menu item.
 ==== Duplicate ==== ==== Duplicate ====
  
Line 221: Line 227:
 ==== Insert Action by Name ==== ==== Insert Action by Name ====
  
-The *Insert Action by Name* command in the *Edit* menu lets you insert any of the many [[Macro Actions|actions]] available in Keyboard~~Maestro by name.+The *By Name* command in the *Edit ➤ Insert Action* menu lets you insert any of the many [[Macro Actions|actions]] available in Keyboard~~Maestro by name.
  
 ==== Insert Function ==== ==== Insert Function ====
Line 231: Line 237:
 ==== Insert Function by Name ==== ==== Insert Function by Name ====
  
-The *Insert Function by Name* command in the *Edit* menu lets you insert any of the many [[Calculations|functions]] available in Keyboard~~Maestro by name.+The *By Name* command in the *Edit ➤ Insert Function* menu lets you insert any of the many [[Calculations|functions]] available in Keyboard~~Maestro by name.
  
 ==== Insert Token ==== ==== Insert Token ====
Line 239: Line 245:
 Most text fields in Keyboard Maestro can process Tokens. ​ These fields are indicated by having a BUTTON{{{T}}} in the field while editing. Most text fields in Keyboard Maestro can process Tokens. ​ These fields are indicated by having a BUTTON{{{T}}} in the field while editing.
  
-==== Insert ​Function ​by Name ====+==== Insert ​Token by Name ====
  
-The *Insert Function by Name* command in the *Edit* menu lets you insert any of the many [[Calculations|functions]] available in Keyboard~~Maestro by name.+The *By Name* command in the *Edit ➤ Insert Token* menu lets you insert any of the many [[Tokens|tokens]] available in Keyboard~~Maestro by name.
  
 ==== Insert Variable ==== ==== Insert Variable ====
Line 249: Line 255:
 ==== Insert Variable by Name ==== ==== Insert Variable by Name ====
  
-The *Insert Variable by Name* command in the *Edit* menu lets you insert any of your variables by name.+The *By Name* command in the *Edit ➤ Insert Variable* menu lets you insert any of your variables by name.
  
 ==== Automatic Completions ==== ==== Automatic Completions ====
Line 262: Line 268:
 ==== Sort Macros by Name ==== ==== Sort Macros by Name ====
  
-The *Sort Macros by Name* command in the *View* menu sorts the macros in the main window by name.+The *Name* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by name.
  
 ==== Sort Macros by Trigger ==== ==== Sort Macros by Trigger ====
  
-The *Sort Macros by Trigger* command in the *View* menu sorts the macros in the main window by trigger. ​ This is useful to see what hot keys are available, or to group all Typed~~String triggers together.+The *Trigger* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by trigger. ​ This is useful to see what hot keys are available, or to group all Typed~~String triggers together.
  
 ==== Sort Macros by Date Created ==== ==== Sort Macros by Date Created ====
  
-The *Sort Macros by Date Created* command in the *View* menu sorts the macros in the main window by the date created.+The *Date Created* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by the date created.
  
 ==== Sort Macros by Date Modified ==== ==== Sort Macros by Date Modified ====
  
-The *Sort Macros by Date Modified* command in the *View* menu sorts the macros in the main window by the date modified (most recently modified at the top).  This is useful to see what macros you have recently modified. ​ You can also use the BUTTON{{{◷}}} button at the top of the macro editor to show the recently modified macros.+The *Date Modified* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by the date modified (most recently modified at the top).  This is useful to see what macros you have recently modified. ​ You can also use the BUTTON{{{◷}}} button at the top of the macro editor to show the recently modified macros.
  
 ==== Sort Macros by Date Used ==== ==== Sort Macros by Date Used ====
  
-The *Sort Macros by Date Used* command in the *View* menu sorts the macros in the main window by date used (most recently executed at the top).  This is useful to see what macros you have recently executed, especially if you think one might have been executed inadvertently. ​ You can also use the BUTTON{{{⌘}}} button at the top of the macro editor to show the recently used macros.+The *Date Used* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by date used (most recently executed at the top).  This is useful to see what macros you have recently executed, especially if you think one might have been executed inadvertently. ​ You can also use the BUTTON{{{⌘}}} button at the top of the macro editor to show the recently used macros.
  
 ==== Sort Macros by Use Count ==== ==== Sort Macros by Use Count ====
  
-The *Sort Macros by Use Count* command in the *View* menu sorts the macros in the main window by use count (most used macros at the top).+The *Use Count* command in the *View ➤ Sort Macros by* menu sorts the macros in the main window by use count (most used macros at the top).
  
 ==== Sort Macros by Time Saved ==== ==== Sort Macros by Time Saved ====
  
-The *Sort Macros by Time Saved* command in the *View* menu sorts the macros in the main window by time saved (most time saved at the top).+The *Time Saved* command in the * View ➤ Sort Macros by* menu sorts the macros in the main window by time saved (most time saved at the top)
 + 
 +==== Disabled to Bottom ==== 
 + 
 +The *Disabled to Bottom* command in the *View ➤ Sort Macros by* menu sorts the disabled macros to the bottom of the macro list.
  
 ==== Select Groups Column ==== ==== Select Groups Column ====
Line 302: Line 312:
 ==== Select Macro by Name ==== ==== Select Macro by Name ====
  
-The *Select Macro by Name* menu in the *View* menu lets you select a macro by name.+The *By Name* menu in the *View ➤ Select Macro* menu lets you select a macro by name
 + 
 +==== Select Macro Last Used ==== 
 + 
 +The *Last Used* menu in the *View ➤ Select Macro* menu lets you select the most recently triggered macro. 
 + 
 +==== Select Macro Last Edited ==== 
 + 
 +The *Last Edited* menu in the *View ➤ Select Macro* menu lets you select the most recently edited macro. 
 + 
 +==== Select Macro Previous Edited ==== 
 + 
 +The *Previous Edited* menu in the *View ➤ Select Macro* menu lets you select the previous edited macro (edited macros form a list, and this moves backward along the list). 
 + 
 +==== Select Macro Next Edited ==== 
 + 
 +The *Next Edited* menu in the *View ➤ Select Macro* menu lets you select the next edited macro (edited macros form a list, and this moves forward along the list).
  
 ==== Reveal Parent Group ==== ==== Reveal Parent Group ====
Line 332: Line 358:
 The *Stop Editing Macros* command in the *View* menu turns off edit mode. The *Stop Editing Macros* command in the *View* menu turns off edit mode.
  
-==== Edit Name ====+==== Rename ​====
  
-The *Edit Name* command in the *View* menu edits the name of the currently selected Macro Group or Macro.+The *Rename* command in the *View* menu edits the name of the currently selected Macro Group or Macro.
  
 ==== Record ==== ==== Record ====
Line 342: Line 368:
 ==== Record Without Delay ==== ==== Record Without Delay ====
  
-The *Record Without Delay* command in the *View* menu toggles recording on and off immediately (without the normal short countdown). ​ It is available while editing a macro. ​ Hold the option ​key down to select the menu.+The *Record Without Delay* command in the *View* menu toggles recording on and off immediately (without the normal short countdown). ​ It is available while editing a macro. ​ Hold the shift key down to select the menu
 + 
 +==== Enter Full Screen ==== 
 + 
 +The *Enter Full Screen* command in the *View* menu will expand the window to full screen.
  
 ===== Actions ===== ===== Actions =====
Line 370: Line 400:
 ==== Set Color ==== ==== Set Color ====
  
-The *Set Color* menu in the *Actions* menu sets the color of actions.+The *Set Color* menu in the *Actions* menu sets the color of actions. ​ 
 + 
 +Note: A blue striped color is reserved to mark the action as a match for the current search. 
  
 ==== Set Note ==== ==== Set Note ====
  
 The *Set Note* command in the *Actions* menu sets the notes of actions. The *Set Note* command in the *Actions* menu sets the notes of actions.
- 
-==== Copy as Text ==== 
- 
-The *Copy as Text* command in the *Actions* menu copies the selected actions as text. 
- 
-==== Copy as Image ==== 
- 
-The *Copy as Image* command in the *Actions* menu copies the selected actions as an image. 
- 
-==== Copy as XML ==== 
- 
-The *Copy as XML* command in the *Actions* menu copies the selected actions as XML. 
  
 ==== Paste Above ==== ==== Paste Above ====
Line 474: Line 495:
 ==== Keyboard Maestro Editor ==== ==== Keyboard Maestro Editor ====
  
-The *Keyboard Maestro Editor* command in the *Window* menu brings the main Keyboard Maestro macro editing window to the front.+The *Keyboard Maestro Editor* command in the *Window* menu brings the frontmost ​Keyboard Maestro macro editing window to the front.
  
 ==== Macro Library ==== ==== Macro Library ====
Line 496: Line 517:
 ==== Mouse Display ==== ==== Mouse Display ====
  
-The *Mouse Display* command in the *Window* menu shows or hides the Mouse Display.+The *Mouse Display* command in the *Window* menu shows or hides the Mouse Display, which shows the mouse location in real time.
  
 See also the [[Windows#​Mouse_Display_Window|Mouse Display Window]] section. See also the [[Windows#​Mouse_Display_Window|Mouse Display Window]] section.
 +
 +==== Value Inspector ====
 +
 +The *Value Inspector* command in the *Window* menu shows or hides the Value Inspector, which shows values of variables, tokens, calculations,​ or clipboards that you can select.
 +
 +See also the [[#​Windows#​Value_Inspector_Window| Value Inspector Window]] section.
  
 ==== Bring All to Front ==== ==== Bring All to Front ====
Line 508: Line 535:
 The *Help* menu contains menu items relating to Help.  You can also use the search field in this menu to find help on the wiki. The *Help* menu contains menu items relating to Help.  You can also use the search field in this menu to find help on the wiki.
  
-==== Keyboard Maestro ​Documentation ​====+==== Interactive Help ==== 
 + 
 +The *Interactive Help* command in the *Help* menu starts the in-application assistance system. ​ If you're having trouble with something not working the way you expect, this system may help you find out where the problem is, or offer suggestions for other sources os assistance. 
 + 
 +==== Keyboard Maestro ​User Manual ​====
  
-The *Keyboard Maestro ​Documentation* command in the *Help* menu displays the Keyboard~~Maestro ​documentation web site.+The *Keyboard Maestro ​User Manual* command in the *Help* menu displays the Keyboard~~Maestro ​user manual on the Keyboard Maestro Wiki.
  
 ==== Keyboard Maestro Quick Start ==== ==== Keyboard Maestro Quick Start ====
Line 539: Line 570:
  
 The *Tutorial* command in the *Help* menu starts the in-application tutorial. ​ The tutorial will walk you through creating a simple macro. ​ By varying the actions slightly, you can create a variety of macros that are triggered by hot keys and that open various documents. The *Tutorial* command in the *Help* menu starts the in-application tutorial. ​ The tutorial will walk you through creating a simple macro. ​ By varying the actions slightly, you can create a variety of macros that are triggered by hot keys and that open various documents.
- 
-==== Assistance ==== 
- 
-The *Assistance* command in the *Help* menu starts the in-application assistance system. ​ If you're having trouble with something not working the way you expect, this system may help you find out where the problem is, or offer suggestions for other sources os assistance. 
  
 ==== Practice Gestures ==== ==== Practice Gestures ====
Line 559: Line 586:
  
 The *Regular Expression Unicode Properties* command in the *Help* menu takes you to the Regular Expression Unicode Properties web site. The *Regular Expression Unicode Properties* command in the *Help* menu takes you to the Regular Expression Unicode Properties web site.
 +
 +==== MacSparky Field Guide ====
 +
 +The *MacSparky Field Guide* command in the *Help* menu takes you to the [[https://​learn.macsparky.com/​p/​km|MacSparky Field Guide]], a high quality, tech-savvy, video tutorial on using Keyboard Maestro from David Sparks.
 +
 +==== Elgato Stream Deck Details ====
 +
 +The *Elgato Stream Deck Details* command in the *Help* menu takes you to the [[/Stream Deck]] page, which includes details about installing the plugin and working with a Stream Deck from Keyboard Maestro.
  
 ==== Third Party Licenses ==== ==== Third Party Licenses ====
Line 596: Line 631:
 ==== Activate Clipboard History Switcher ==== ==== Activate Clipboard History Switcher ====
  
-The *Activate Clipboard History Switcher* command ​in the *Paste* menu in the *Status Menu* menu lets you activate the [[manual:​Clipboard_History_Switcher|Clipboard History Switcher]].+The *Activate Clipboard History Switcher* command in the *Status Menu ➤ Paste* menu lets you activate the [[manual:​Clipboard_History_Switcher|Clipboard History Switcher]].
 ==== Your Macros ==== ==== Your Macros ====
  
Line 602: Line 637:
  
 This is great for less frequently used macros that you will not remember a hot key or other trigger, as well as for macros that *feel like* they should be menu commands, such as actions that *perform* a complicated task. This is great for less frequently used macros that you will not remember a hot key or other trigger, as well as for macros that *feel like* they should be menu commands, such as actions that *perform* a complicated task.
 +
 +==== Show Applications Palette ====
 +
 +Toggles the display of the [[Palettes#​Applications_Palette | Applications Palette]].
 +
 +
  
 ==== Recent ==== ==== Recent ====
manual/Menus.1531345501.txt.gz · Last modified: 2018/07/11 17:45 by JMichaelTX