User Tools

Site Tools


Forum

Go To Forum

Using the Keyboard Maestro Forum

Where To Post


Before Asking

Before you post a question to the Keyboard Maestro Forum please:

  • Spend a little time looking through the Keyboard Maestro User Manual.
  • Use search within the Keyboard Maestro Editor Help menu to try to find related actions.
  • Spend at least 5-10 minutes searching within the forum itself and with Google.

Even if you don't find what you're looking for you'll improve your knowledge of how to use Keyboard Maestro, and there's a good chance you'll ask better questions on the forum because of it.


How To Get Help

If you can't find the answers you need in the Keyboard Maestro Wiki or (User Manual), then the Keyboard Maestro Forum is a great resource to

  • Search for Q&A and Other Macros/Solutions Related to Your Issue
  • Post your questions and issues, and get help from fellow users as well as from the Keyboard Maestro owner himself.
  • Share your completed, working, macro to help others like you.

Searching the Forum for Answers

There are two ways to search the Forum:

  1. Using the Forum Search Tool by clicking on the magnifying glass (🔍) at the top right of the Forum window
  2. Using the Google site search
    1. Just like a normal Google Search, except include site:forum.keyboardmaestro.com along with your keywords:
      site:forum.keyboardmaestro.com YourKeyWords

Posting Your Question or Issue to the Forum

If you are having trouble with a macro and want help, then please post:

  • Your question with as much detail as you can
  • If it involves processing data, provide real world (not madeup) examples of:
    • Your source input data
    • How you want the data to appear after processing by your macro
  • Upload both your macro image and code (export of macro)

For help on using the Forum Editor, see Using Markdown in the Keyboard Maestro Forum

This will help others to understand your issue, and to test the macro if need be.
To get the best, fastest answer to your question, provide us with the best info you can.


How to Post/Upload Your Macro to the Forum

From the Keyboard Maestro Editor

  1. For Keyboard Maestro Version 7+, use the Share button (see #1 below)
  2. For all versions of Keyboard Maestro, save to files, then import (see #2, Manual Upload, below)

1. Upload Using Share Button

(Available for Keyboard Maestro version 7+ only)

This will create a new topic in the forum category you select.

  1. Click on the Macro name in the Editor
  2. Click on the Share button
  3. Change the “Category” to “Macro” if you are sharing a working macro for others to use
  4. Leave the “Category” on “General” if you are asking a question related to the macro
  5. Click on the “Both” button
  6. :!: Note: If you just click on the “New Topic” button, it will NOT upload your macro.

To move the uploads to an existing topic, see instructions below these screenshots.


and then this popup will appear

To MOVE to an existing topic, then AFTER the new topic is created:

  1. Select ALL in the new topic
  2. CUT the selection
  3. Cancel/Abort the new topic
  4. Goto the existing topic
  5. Create a reply
  6. PASTE into the reply block

See this video: How To Upload Macro to Existing Post in Keyboard Maestro Forum


2. Manual Upload

Follow these steps to manually export your macro to files, then upload

  1. Click on the macro name in the Keyboard Maestro Editor
  2. Goto File > Export Macro, and save wherever you'd like
  3. Goto Edit > Copy as > Copy as Image
  4. Open Mac Preview app, and goto File > New from Clipboard, and save.
  5. Go to the Keyboard Maestro forum thread, and click on reply
  6. Enter some descriptive text,
  7. Use the file upload button in the Keyboard Maestro Forum Editor to upload both files.
    1. OR drag and drop files from the Finder into the Keyboard Maestro Forum Editor.
    2. OR using most web browsers other than Safari you can copy and paste into the Keyboard Maestro Forum Editor.
      1. Images in the Clipboard or files copied from the Finder can be pasted.
  8. The Select Clipboard Image File macro may also be useful for posting images.

The items uploaded (shared) will be those items which are SELECTED in the editor:

  • If you have selected a macro in the macro list, then it will be uploaded
  • If you have selected one or more Actions in a Macro, then only the Action(s) will be uploaded.

Original article posted by: Christopher Stone 2015/11/12 20:19

Forum.txt · Last modified: 2017/09/08 04:29 by peternlewis