User Tools

Site Tools


manual:Macro_Actions

Macro Actions

A Macro executes a sequence of Macro Actions in order. There are many actions to choose from. Some simple actions, such as Sleep Computer, require no other information and simply do their job, while other more complex actions, such as Select Menu Item, require you to specify more information, such as a target application or menu name. You do this by editing the values for the action.
Keyboard Maestro actions have two very distinct types of fields: text token fields and numeric calculation fields. You can learn more on the wiki Text Fields page.

There are many powerful Macro Actions available for your use, and you can sequence them together to perform complex tasks.

To add an action, edit your macro, click the New Action button, or equivalently the + button below the detail view. This will show the lists of possible actions.

To see all actions, select the All Actions category. To select just your favorite actions, select the Favorites category. You can drag actions into your Favorites category. To see plug in actions that you have added to Keyboard Maestro, select the Third Party Plug Ins category.

Double click or drag one or more of the actions to add them to the action list for the currently edited macro.

Alternatively, choose Insert Action by Name from the Edit menu and quickly search for and add an action by name, or select an action from the Insert Action command in the Edit menu.

You can drag Macro Groups or Macros into the action list. With no modifiers, this will create an Execute Macro Action or Show Macro Group action. With the Option key, this will copy in the macro's actions. With Command-Shift, this will create an Enable Macro Group or Macro action. With Option-Shift, this will create a Mark the Macro action.

You can drag a file into the action list. This will create an Activate Application, Execute Script, or Open File action.

You can use the Engroup or Degroup from the Actions menu to enclose actions in other containers (or remove them from containers).

You can enable or disable actions by selecting them and clicking the button at the bottom of the macro detail view. You can set the timeout or other options on an action clicking the menu at the top right of the action and selecting an option.

You can display more or less detail about some actions by clicking the disclosure triangle. You can disclose all the actions (in a sublist) simultaneously by option clicking on the disclosure triangle.

You can try the action immediately by clicking the button at the top right of the action and selecting Try. Alternatively, you can try the selected actions immediately by clicking the Try button at the bottom of the macro detail view.

You can control or right-click on an action to act on it, including pasting other actions above or below it.

You can configure the action using the various menus and text fields, as well as by clicking the button and using the action menu. This allows you to rename actions, color them, add notes, configure their time out and failure behaviour and more.

The action menu also allows you to get help on the specific action.

You can share an action sequence to the Keyboard Maestro Forum, or to a friend via Mail or Messages using the sharing button at the top of the Macros window.

You can learn more about the available actions on the wiki Actions page.

manual/Macro_Actions.txt · Last modified: 2017/08/29 23:57 by peternlewis